summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorstale <redkugelblitzin@gmail.com>2022-05-29 23:56:03 -0300
committerstale <redkugelblitzin@gmail.com>2022-05-29 23:56:03 -0300
commitb1fd887402e4577cbb630fc6517cf9cd6e0d7c8f (patch)
tree7018603244d38a361f86aa0b1a6ea11ea39f27c6 /Cargo.toml
parentc896f3a5f9b2e3f7f03ad1871b6566f098c0e295 (diff)
compression! also bumped edition
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 6356860..8997bdd 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -2,7 +2,7 @@
name = "websweeper"
version = "1.0.0"
authors = ["stale <stale@masba.net>"]
-edition = "2018"
+edition = "2021"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
@@ -10,6 +10,7 @@ edition = "2018"
tokio = { version = "1", features = ["full"] }
serde = { version = "1", features = ["derive"] }
serde_json = "1.0"
+flate2 = "1.0"
warp = { version = "0.3", features = ["tls", "websocket"] }
rand = "0.8"
futures-util = "0.3"